Mail Delay Issues at SendGrid (our email service provider)
Incident Report for Brick River
Resolved
SendGrid has resolved their issue.
Posted Jul 28, 2020 - 16:59 EDT
Update
Looks like SendGrid got it figured out but are still trying to get some emails unstuck from this morning. They write...

"At this time, we are receiving and delivering mail as expected (NOT including Legacy or New Marketing Campaigns). Due to an issue in one of our data centers this morning, mail received from approximately 6:00AM MT - 6:15AM MT is still stuck in delivery."
Posted Jul 28, 2020 - 14:27 EDT
Monitoring
SendGrid (our email service provider) is having delivery delay issues currently so that means some of your emails are delayed too.

I'll let you know when it resolves itself but you can check their status here as well: https://status.sendgrid.com/
Posted Jul 28, 2020 - 14:09 EDT
This incident affected: Brick River Emailer.