Something going on with our DB that's affecting the emailer
Incident Report for Brick River
Resolved
I'm closing this out. Everything continues to be fine.

We see that the reason appears that a bot called Seekport crawled one particular client's page that has three thousand links to pages that are very database intensive.
None of the pages were in cache at the time so every request made a new database request.
That used 100% of the database for about 20 minutes.

The version 3 of Brick River that we're working on will help with issues like this.
Posted Nov 29, 2021 - 11:18 EST
Update
Everything continues to work okay. The database is running fine now, but we are still investigating the root cause.
Posted Nov 29, 2021 - 10:37 EST
Monitoring
The issue was the database being 100% utilized and we're investigating why that was. It was affecting everything. BUT now the DB utilization is now down to a normal level.
Posted Nov 29, 2021 - 10:07 EST
Investigating
There is something going on right now that is affecting the emailer. We're on it.
Posted Nov 29, 2021 - 10:01 EST
This incident affected: Brick River Emailer.