Slow emailing... queueing
Incident Report for Brick River
Resolved
It was an issue on SendGrid and here's what their tech support told us...

Following up on our chat from earlier, I wanted let you know that the issue causing those deferrals has been mitigated, and your mail is sending as normal again. Just to be sure: I double-checked the mail that was in a processing state. I'm now seeing the majority of that mail has since been delivered. Anything leftover will be delivered shortly as we process all of those deferred messages.
Posted Nov 26, 2019 - 12:39 EST
Investigating
Some customers have sent emails and those emails have not been sent yet. The problem is at SendGrid our ESP (email service provider). Their people are looking into it. I'll let you know more as we have info.
Posted Nov 26, 2019 - 11:34 EST
This incident affected: Brick River Emailer.